← Back to Knowledge Base

KB #240070: Error “The specified file is not encrypted” when starting SQL

⏱️ 1 min read

Type:

Information

Summary:

You secured the instance of SQL specifying “Master must be encrypted” and either master.mdf is not encrypted, or Encryptionizer could not access master.mdf.

Additional Information:

First, use the Encrypt/Decrypt Wizard to verify that master.mdf is actually encrypted. If it is, that means that Encryptionizer cannot access the directory that master.mdf is located in (permissions issue for the startup account).

Start Control Panel, Administrative Tools, Services (or run services.msc). Locate the Service entry for your instance of SQL Server. This is usually MSSQL$instance_name if a named instance, or MSSQLSERVER if the default instance.

Select the Log On tab. If the “this account” button is selected, make sure that the account specified has at least Read access to the SQL Data directory (or whichever directory master.mdf is located in, if different.)

Special Tip for SQL Express

By default, SQL Express uses the NETWORKSERVICE account. We recommend that you change this to the Local System Account or other privileged account.

Was this article helpful?

Related Articles

KB #240130: Operator password was set for this utility

Type: Fix Applies to: Encryptionizer Key Manager (EKM) Server To Reproduce: Apply Operator password to…

KB #240056: Encrypt/Decrypt Wizard: Error – could not access file

Type: Tip Summary: The Encryptionizer Encrypt/Decrypt Wizard must have access to a file to be…

KB #240052: Torn Page (Error 823) error at offset 0 when opening encrypted database

Type: Information Summary: A Torn Page error at offset 0x0000000000000000 will occur when trying to…

Still need help?

Our support team is here to assist you.

NetLib Security
AI Assistant · Online
Hi! I'm the NetLib Security assistant. I can answer questions about our encryption solutions, HIPAA compliance, Encryptionizer, and more. How can I help you today?