← Back to Knowledge Base

KB #240095: User not being prompted to enter key when SQL starts

⏱️ 1 min read

Type:

Information

Summary:

Even though “??” was specified as the key when building the security profile, SQL hangs at startup and user is not presented with a key entry dialog. NOTE: This is an option when securing SQL and most do not use this method.

Additional Information:

If you have specified ?? (two question marks) as a key when creating the security profile, the user is prompted with a dialog at SQL Startup to enter the key value. In Windows 2008 R2 and later you need to have Windows’ “Interactive Services Detection” Service running in order to interact with a Service from the Desktop:

To start this Service:

  • Start Administrative Tools->Services (run Run “services.msc”).
  • Locate the Interactive Services Detection Service.
  • Start the Service.
  • Change the Start type from Manual to Automatic so it will be started automatically next time you reboot.

If functioning properly, when starting SQL next time you will see an icon flashing on the Task Bar prompting you to interact with a Service.

Was this article helpful?

Related Articles

KB #240052: Torn Page (Error 823) error at offset 0 when opening encrypted database

Type: Information Summary: A Torn Page error at offset 0x0000000000000000 will occur when trying to…

KB #240100: SQL Backup not encrypted

Type: Information Summary: The encryption state of a database does not determine the encryption state…

KB #240116: Enabling CLR in a SQL instance for use with Encryptionizer SQL API’s

Type: Information Summary: CLR is a more efficient method of executing NetLib SQL API’s than…

Still need help?

Our support team is here to assist you.

NetLib Security
AI Assistant · Online
Hi! I'm the NetLib Security assistant. I can answer questions about our encryption solutions, HIPAA compliance, Encryptionizer, and more. How can I help you today?